8 Antworten zu “Guhgell (internetz-konzern) ist nicht fähig, sonderzeichen in einer webseit zu kohdieren…

    • Na, diese komischen deutschen vokale mit pünktchen drüber. Offenbar haben die es in unikohd als komposizjonen gemacht, aber vergessen, im Content-type einen charset anzugeben. Das lernen die aber noch bei guhgell…

      • Ganz sicher bin ich mir nicht, aber ich vermute mal, da sind Kodierungen gemischt. Einmal vom Output her, und einmal was in der Datenbank steht oder eingestellt ist.

        Bin mir nicht sicher ob das einfach zu beheben ist, aber ich hatte da schon massiv Probleme wenn die Koalition nicht zu dem passt was letztendlich ausgegeben wird. Oder ANSI und UTF in der Datenbank gemischt sind. Da hatte ich schon den Fall, je nachdem was man einstellt, z.B. per Apache, andere Zeichen falsch dargestellt wurden.

        • Einmal ganz davon abgesehen, dass so etwas ein albtraum ist: die box ist ein IFRAME, und das darin dargestellte dokument ist UTF-8, hat aber im header keinen angegebenen charset. Mein opera verwendet als standard, wenns der sörver oder ein meta http-equiv nicht anders sagen, ISO-8859-1 — weil das meistens richtig ist, wenn nichts explizit angegeben wird. Jedenfalls für die sprachen, die ich lesen kann… 😉

          Guhgell hat es hier in einem dokument richtig gemacht, und in einem anderen nicht so. Dass in diesem anderen drinsteht, dass man auf jede privatsfähre verzichtet und so weiter, und dass ausgerechnet das nicht mehr leicht lesbar ist, ist bestimmt nur so ein dummer zufall.

          • Ah THX. Auf IFRAME bin ich gar nicht gekommen. Wer macht denn so etwas und warum? Ist das etwa nen IFRAME Baukasten für BWLer? 😆

            Dann müsste aber theoretisch die äussere Seite falsch dargestellt werden, wenn du den Browser auf UTF-8 stellst, damit das Ihhhh-Fraeim richtig dargestellt wird – oder?

            ISO-8859-1 – Naja. Macht man das heute noch? Ist Unicode nicht die bessere Wahl (aus Entwicklersicht)? Eben wegen der versch. Locale-Sonderheiten.

          • Da, wo der websörver kein encoding explizit übermittelt, habe ich es mit so alten projekten zu tun, dass unicode eine seltenheit ist. 😉

        • Du wirst vielleicht lachen, aber die oben genannten Probleme hatte ich auch mit älteren Daten. 😉
          Genauer mit nem Update und dem Umzug einer uralt osCommerce Installation.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.